Luma Touch Support Forums

Welcome to the Luma Touch community forums, a great place to get help and share ideas with other users. The registration code can be found in the App Store release notes or contact
It is currently Tue Mar 20, 2018 8:50 am

All times are UTC-07:00

For answers to frequently asked questions please see our support page You can contact us from our support page, or email us directly at

LumaFusion 1.5.3 is now available on the App Store. This update adds Korean Localization, new aspect ratios, and fixes some issues

LumaFX 2.5 is now available on the App Store. This adds new ways to import media, and fixes the issue with importing LUTs

Forum rules

We strive to provide a safe, fun environment for our forum members to discuss our apps, and other related creative tools and experiences. We will not tolerate disrespectful comments to other members. Please keep comments topical, and criticisms positive.

Post new topic  Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Wed Oct 11, 2017 7:53 pm 

Joined: Tue Oct 10, 2017 6:19 pm
Posts: 3
Hi everyone, had another newbie question.

I am working with a project and want to insert a full video clip at the beginning of my project. I tried dragging the timeline to the beginning and inserting it, but it just overlays the audio on top of what is currently the beginning. How can I insert this into the beginning?


PostPosted: Thu Oct 12, 2017 11:26 am 
User avatar

Joined: Sat Mar 02, 2013 10:54 pm
Posts: 337
I can't figure out why you just get the audio on top but I wonder if you might have accidentally switched to overwrite mode instead of the normal insert mode.
Look at the far left end of the main video track. There should be a white insert symbol showing at the edge of the screen (looks like a right pointing arrow on a plate).
If there is no white symbol you are in overwrite mode. Tap on where the symbol should be to switch back to insert mode.

Overwrite mode is very useful when you have a nearly completed project and you want to adjust a section without disturbing the timing of other clips. Yes it seems a bit odd that the symbol disappears instead of changing or being crossed.


Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 2 posts ] 

All times are UTC-07:00

Who is online

Users browsing this forum: Google [Bot] and 2 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Limited