Luma Touch Support Forums

Welcome to the Luma Touch community forums, a great place to get help and share ideas with other users. The registration code can be found by emailing
It is currently Wed Jan 16, 2019 8:13 pm

All times are UTC-07:00

For answers to frequently asked questions and to contact us directly, please use our support page at

LumaFusion 1.7 is now available in the App Store. This update includes great new features like search and sort in the library, soft edges and curved corners in cropping, and our new integration with Storyblocks, a great royalty-free library of video, audio and sound effects. A sample of clips are included free, with a low-cost subscription available in-app for access to the full library

Forum rules

We strive to provide a safe, fun environment for our forum members to discuss our apps, and other related creative tools and experiences. We will not tolerate disrespectful comments to other members. Please keep comments topical, and criticisms positive.

Post new topic  Reply to topic  [ 5 posts ] 
Author Message
PostPosted: Fri Sep 15, 2017 4:10 pm 

Joined: Sun Mar 05, 2017 8:38 am
Posts: 35
Help! The bad news is that my iPad was stolen. The good news is that I got myself a new tablet, iPad 2017, not pro. Model number MP2H2LL/A. More good news, my video that I have been working on for months was saved. When I went to download everything on my new iPad, there was the video. The bad news is that not everything is working. I don't know what to do. I downloaded all the videos. The only thing that really saved in the video was the photos. The videos have lines across them, so I can see which video is supposed to be there. Am I going to have to do the complete thing over by hand or is there a problem with the way they were saved? All my Videos were saved in Google Photos. I downloaded them back into my Camera section and then saved them over into LumaFusion. Did I do that wrong? Should've I imported them from Google Photos into another section? Or is my tablet more up-to-date than my Lumafusion program? I'm so happy with LumaFusion! I really really love it. I'm just happy that it saved as much as it did. But I have a lot of work to do all over again if I can't get those videos in there. I tried to put them in by hand and delete the one that wasn't working. But it still has the red and blue ribbons across it. What's the problem? What am I doing wrong? There should be a picture with this.

UPDATE: The copy I had made was almost completely intact! Don't know why the other one was completely missing. I will only have to reload a couple of pictures. I don't really need help now except to understand why the pictures are missing in one and not in the other. Thanks!

Thank you!

PostPosted: Tue Sep 19, 2017 10:26 am 
User avatar

Joined: Fri Jun 30, 2017 11:16 am
Posts: 132
Location: Moscow
Hello Dom.
Pictures, photos, and especially video are large files.
When you receive a new tablet, in this case it takes time for such files to download to the tablet from Apple's servers, where they are duplicated under your account.
This operation can not be performed instantly.

And at the beginning of the work with the new tablet, you see only the names of the files, and their contents have not yet been copied completely to the tablet.

This is depend on the speed of Wi-Fi connection.

If the previous tablet was large and heavily filled, the recovery process "by air" can take more than one day.
After all, the photo-video library is the largest in terms of size.
It remains only to choose a fast Wi-Fi and wait.

I can advise you to leave the device at night connected to the Wi-Fi and power supply. This is also recommended for a successful backup process in iCloud.

~ When they played I'd sing along, it made me smile ~

PostPosted: Tue Sep 19, 2017 2:47 pm 
Site Admin
Site Admin

Joined: Mon Feb 25, 2013 6:17 pm
Posts: 1366
Hello Dom

sounds like lumaluke is right. Did the missing media have little cloud icon on it? That indicates that the media is in the cloud but not on the device.


Androu Morgan


PostPosted: Sun Jan 14, 2018 7:09 pm 

Joined: Sun Jan 14, 2018 7:02 pm
Posts: 1
Hi there! LOVE this app!! Thank you thank you thank you to all the developers and creators of it.

I am running into the issue with the cloud icon on recent footage shot. I have about 27GB of storage on my ipad and the shots are only about 30-90seconds long. I've tried downloading the clips to no avail. I'm wondering if the issue is with my photos app. I've also noticed that all footage that I recently shot on the filmic pro app seems to not save.

Any information or help with be greatly appreciated!


I figured it out-I had to airdrop the videos again to my ipad-worked this time

PostPosted: Wed Feb 14, 2018 8:30 pm 

Joined: Mon Mar 20, 2017 7:47 pm
Posts: 14
1.5.1 still needs video /photos downloading at times for some of the media, but not all

Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 5 posts ] 

All times are UTC-07:00

Who is online

Users browsing this forum: No registered users and 1 guest

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Limited