Luma Touch Support Forums

Welcome to the Luma Touch community forums, a great place to get help and share ideas with other users. The registration code can be found by emailing support@luma-touch.com.
It is currently Sun Aug 25, 2019 9:12 am

All times are UTC-07:00


For answers to frequently asked questions and to contact us directly, please use our support page at https://luma-touch.com/support.

LumaFusion 2.0 is now available in the App Store. This is a massive new update that doubles the number of tracks for video and audio, streamlines the user interface, and much more.


Post new topic  Reply to topic  [ 25 posts ]  Go to page 1 2 3 Next
Author Message
PostPosted: Fri Mar 22, 2019 4:23 pm 
Offline
Expert
Expert
User avatar

Joined: Sat Mar 02, 2013 10:54 pm
Posts: 485
I was having trouble editing projects with lots of short 4K clips imported from my (wonderful!) Osmo Pocket into User Media in LumaFusion. After the first few clips the preview and editing performance would become very jerky and laggy. This persisted even when changing the preview setting to fastest.

I normally avoid using the Photos app because iCloud insists on uploading every clip but I noticed that the same clips from Photos performed much better in LumaFusion so presumably there was some kind of format problem. I tried to research this but probably not enough. Format details aren’t my thing - I just want it to work!

Then I had an idea and I’m pleased to say it solves the problem beautifully. Instead of importing the files directly I shared them with a simple Shortcut that re-encodes them into HEVC first. I could select a bunch of files, use the Shortcut from the Share menu, wait for a bit for them to be encoded and then choose the LumaFusion User Media folder as the destination.

Hope this might help someone else. The only proviso is to limit the number of videos in a batch to something the iPad can handle. I can do 20+ but 100 just stalls.

PS. also worked well with 60 FPS 4K


Attachments:
5B21BD67-5323-457C-8CEA-28B82873BF0E.jpeg
5B21BD67-5323-457C-8CEA-28B82873BF0E.jpeg [ 283.58 KiB | Viewed 2509 times ]

_________________
Mark
Top
   
PostPosted: Tue Mar 26, 2019 1:13 am 
Offline
Apprentice
Apprentice
User avatar

Joined: Fri Jul 13, 2018 10:24 am
Posts: 96
Thanks Mark

_________________
Rene


Top
   
PostPosted: Thu Mar 28, 2019 10:06 am 
Offline
Apprentice
Apprentice
User avatar

Joined: Fri Jul 13, 2018 10:24 am
Posts: 96
Hi Mark,

I made some test with a file from my Osmo Poket, 4k / 60Fps

- original file : 402 MB - 100 Mb/s ( imported directely to LF )
- after the shortcut « Video to Luma » : 98.8 MB - 24.4 Mb/s (imported to Photo)

That is the reason why it is easier to edit the file in photo with LF

For youtube 4k/60Fps, the bit rate to advocate by youtube is 20 to 52 Mb/s

_________________
Rene


Top
   
PostPosted: Thu Mar 28, 2019 1:31 pm 
Offline
Expert
Expert
User avatar

Joined: Sat Mar 02, 2013 10:54 pm
Posts: 485
Thanks Rene. I thought it would be something like that.

_________________
Mark


Top
   
PostPosted: Sun Mar 31, 2019 9:21 pm 
Offline
Apprentice
Apprentice
User avatar

Joined: Fri Jul 13, 2018 10:24 am
Posts: 96
Mark,
I have modified the “shortcut ” with a loop and I save the resulat in photo after one conversion
I had more than 60 files to be converted, the shortcut crash, because not enought memory ta save the intermediate results before saving to photo.
With this procedure , you can also see the status during convertion if you display shortcut and photo at the same time on the screen.


Attachments:
995839E1-DEEA-419A-8CED-5E7B22766F8D.png
995839E1-DEEA-419A-8CED-5E7B22766F8D.png [ 4.05 MiB | Viewed 2051 times ]

_________________
Rene
Top
   
PostPosted: Sun Mar 31, 2019 10:48 pm 
Offline
Expert
Expert
User avatar

Joined: Sat Mar 02, 2013 10:54 pm
Posts: 485
Merci Rene. A loop is a good idea because as you say too many files create a memory problem. Sending them to Photos is a good way of checking progress but I like to avoid Photos because I use iCloud photos and don’t want it trying to upload all the raw clips. Another way of checking progress is to get the shortcut to send a notification after every ten clips.

_________________
Mark


Top
   
PostPosted: Thu Apr 04, 2019 10:08 am 
Offline
Apprentice
Apprentice
User avatar

Joined: Fri Jul 13, 2018 10:24 am
Posts: 96
Hi Mark,
If you import a file with 60fps from osmo pocket and then convert this video with your shortcut, can LF display the video.
I have a black screen !
All my other applications can read, modify... the file without problems.
I’ve explained the problem to LF support.


Attachments:
EA336F02-9574-4679-B780-A846A8B9C7DE.jpeg
EA336F02-9574-4679-B780-A846A8B9C7DE.jpeg [ 374.46 KiB | Viewed 1844 times ]

_________________
Rene
Top
   
PostPosted: Thu Apr 04, 2019 6:53 pm 
Offline
Expert
Expert
User avatar

Joined: Sat Mar 02, 2013 10:54 pm
Posts: 485
Hi Rene
I can see the file ok but remember that I don’t save it to Photos from Shortcuts. Instead I save it to the LumaFusion Imported folder (in Files). Also you probably have a different SD card reader which might process it differently (I have an Adata reader).
Can you see the clip normally in the Photos app too? If you can I don’t know why you can’t see it in LumaFusion timeline but you can see it in preview. I seem to remember something similar being mentioned in the forum before so perhaps a search might help. Maybe it’s because the clip is converted to a different frame rate or something. Maybe you don’t have enough memory. Try resetting? Have you tried trimming the clip in LumaFusion?

_________________
Mark


Top
   
PostPosted: Thu Apr 04, 2019 8:28 pm 
Offline
Apprentice
Apprentice
User avatar

Joined: Fri Jul 13, 2018 10:24 am
Posts: 96
Hi Mark,
Thanks for the info, for you LF can read the file.

1) I can display the file in the LF preview
2) I can display the file in photo
3) I can display, edit and create a video with the file in “Imovie”
4) I can display, edit and create a video with the file in “perfect video”
5) I can display the file in “Deshake”
6) I can display the file in “emulsion”
7) I can read information and play the file in “View Exif”
8) I can read information and play the file in “Metapho”

I have 350 GB available on my Ipad :D
Yes I can trim the clip in LF, but it change nothing

My workflow is :

1) recorded with osmo pocket 60 Fps
2) uploaded to my Ipad from am SD card reader to LumaFusion
3) converted with a shortcut to photos

It is not the first time that i had this problem with other files at 25 fps recorded with my phone an stabilized with Emulsion.

If I optimize and consolidate, than it is OK, but I have then 3 times my files in my IPAD... :shock:
... and I have 60 files :D

This is the answer from LF support :
I've duplicated the result and am checking with the broader team. I'll capture this in our bug reports and we'll get this solved as soon as we can. I'm not sure yet what is causing the issue.

_________________
Rene


Top
   
PostPosted: Sat Apr 06, 2019 10:49 pm 
Offline
Expert
Expert
User avatar

Joined: Sat Mar 02, 2013 10:54 pm
Posts: 485
I’m sorry my friend I just can’t replicate this problem. I was wondering if the problem was the speed setting in the Encode Media action in Shortcuts - perhaps the frame rate has to be exactly 60. I tried Custom - 1.0 and this works OK. Normal is also OK.
So I don’t know the answer. I hope the LumaFusion people can help you.

_________________
Mark


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 25 posts ]  Go to page 1 2 3 Next

All times are UTC-07:00


Who is online

Users browsing this forum: Bing [Bot] and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Limited