Luma Touch Support Forums

Welcome to the Luma Touch community forums, a great place to get help and share ideas with other users. The registration code can be found in the App Store release notes or contact
It is currently Sat Mar 17, 2018 7:39 am

All times are UTC-07:00

For answers to frequently asked questions please see our support page You can contact us from our support page, or email us directly at

LumaFusion 1.5.3 is now available on the App Store. This update adds Korean Localization, new aspect ratios, and fixes some issues

LumaFX 2.5 is now available on the App Store. This adds new ways to import media, and fixes the issue with importing LUTs

Post new topic  Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Wed Jun 07, 2017 1:30 am 

Joined: Wed Jun 07, 2017 1:18 am
Posts: 3

I'm editing my first film on Luma Fusion (on the road with my iphone 7) and have been really impressed by the many great functions!

It was all running smoothly at first until I first started getting push-ups that I am unable to insert any transitions; they advised me to contact support if it keeps happening, which it does.

It worked in-between (more-or-less, by allowing me to use only one transition!) and I was really happy to be able to somehow continue working on my project, but now in the meantime, I can't do anything at all! The complete project has completely frozen and I can't work on it at all, except for exceptionally the undo button.

What has gone wrong? I'd like to finish my film and savour the enjoyment of discovering and experimenting with the editing tools stress-free!

Please help!

PS: The pop-up message from you reads (translated from German): "We're having some problems. SOorry but LumaFusion could not give you a preview for this timeline. UNtil the timeline is available again, you can undo your last actions. Please contact us if this problem reoccurs"

PostPosted: Wed Jun 07, 2017 8:46 am 
Site Admin
Site Admin
User avatar

Joined: Mon Feb 18, 2013 11:01 pm
Posts: 2882
Hi Tyberlin,

Sorry you are having this problem. We have been chasing this down but have not been able to get a project that routinely displays it. We do know that if the timeline isn't building correctly, pressing Undo to unbuild the last actions will get you back to before the problem started. Also trimming clips around the last things you did will often fix the problem - but it sounds like you are beyond that point.

Does the export button work? Is there any way you can upload a Project Archive to us. If you are on the iPhone you should make sure that you connect to wi-fi somewhere to do it.

I will send you a log-on for our box account and instructions.

Look for a mail from

Terri Morgan

Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 2 posts ] 

All times are UTC-07:00

Who is online

Users browsing this forum: No registered users and 2 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Limited